[solved] Dual Authentication – CMS and LDAP

Home Forums Troubleshooting Help [solved] Dual Authentication – CMS and LDAP

This topic contains 6 replies, has 2 voices, and was last updated by Avatar of charles charles 9 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #66329
    Avatar of craigreilly
    craigreilly
    Participant

    We have a CMS Login woring fine via Joomla.
    We also want to enable secondary auth using LDAP/Windows AD so users can access the site with the iPad app.
    In the admin side I can conect to server and find user, but in the iPad app, it tells me the account is locked. I am thinking this has something to do with the CMS login redirect.
    Can anyone shed some light on this subject?


    • This topic was modified 9 months, 1 week ago by Avatar of charles charles.
    #66341
    Avatar of craigreilly
    craigreilly
    Participant

    By the way, I did go here:
    http://ajaxplorer.info/plugins/auth/remote/ (refers to broken links)
    and here:

    http://ajaxplorer.info/ajaxplorer-apps/ios-client/


    #66343
    Avatar of charles
    charles
    Keymaster

    That one?

    http://ajaxplorer.info/setting-up-a-remote-authentication-to-your-custom-cms-ii-testing-mobile-access/

    I think you should use only the Joomla Bridge, and let joomla query the LDAP behind, what do you think?


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #66344
    Avatar of craigreilly
    craigreilly
    Participant

    I do have Joomla do the LDAP logon – but I am also trying to get the iPad app up and running… So, this would require LDAP/AD Auth… yes?
    Otherwise, the iPad app « Connection Failed » – so I tried adding the LDAP/AD as secondary authentication, but get the same results.
    I think it has something to do with redirect so the logon form doesn’t show.
    I tried swapping authentication to be LDAP first, CMS second – but then CMS prompts for credentials instead of using CMS credentials.


    #66378
    Avatar of charles
    charles
    Keymaster

    No the iPad app does not require LDAP/AD. You should only use CMS bridge. And read very precisely the article, to enable the users to login from ajaxplorer AS WELL AS from joomla.


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #66414
    Avatar of craigreilly
    craigreilly
    Participant

    I had tried that with no luck…. Thus the reason I went to AD. I have figured it out though.
    For Home node in the Joomla Authentication, it was set to / which was my home page essentially – but I needed to specify /index.php instead. Once I did that all was good.

    Thanks for the push to try the single auth method again…
    My marketing lead will be very happy that this is up and running.

    Best,


    #66434
    Avatar of charles
    charles
    Keymaster

    finally, solved. Great news!
    Charles


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.